Skype ends supporting Mac OS X 10.5.8 and below

By | August 8, 2014

The latest buzz is that Skype ends supporting Mac older versions which runs on OS X 10.5.8 and below, Microsoft yesterday announced that the Skype has ended the older version of Apple’s Mac OS X and below. Actually what happened is few days back the Skype users started to Complain on the company’s forum that they were being locked out from accessing the popular voice over IP Serice as per reports TUAW.

As complaints mounted to increase, then the company people it was guessed that Skype is no longer operation on Mac device which is running older version like 10.5.8 and lower versions. Now Microsoft conformed that change in service is an big and good Answer to question regarding Skype Compatibility with OS X  snow leopard which will for now remain unaffected.

For Reference, Apple’s Mac OS X 10.6 Snow Leopard requires only the Intel processor to run which is absolutely unable to run with eight years old processor. For these old Mac devices the users have fashioned Works around including a method of blocking a software mechanism from connecting it with the servers. even though these bootstrapped solutions are hit-or-miss.

Last month Microsoft announced that old versions of Mac as well as windows to upgrade their software in next few months, forcing current users to upgrade to latest software for uninterrupted service. The company noted users with Skype with Skype for Mac 6.13 and below and Skype for Windows 6.14 and below would be unable to log in until they update. The latest version of Skype For Mac 6.19 is available in the official website which can be downloaded for free.

Author: Micheal Edward Tansey

Micheal, is a loyal Apple Fan. A graduate in computer science, Micheal loves to experiment with iOS and Mac. Here at The Tech Bulletin, he covers information about Apple Products.+Micheal